Not installing or installing erroneously



  • Whenever I go to
    mySite.com/vr
    I get redirected to
    mySite.com/vr/install
    with a page not found error

    I followed the instructions and did add <directory> ... </directory> to apache2. In fact, I changed httpd.conf of apache2 even. But still doesn't work.

    Did restart apache

    However, if I do
    mySite.com/vr/index.php, I can install and actually upload some models. But eventually publishing doesn't show the 3d models because all the model links are having 'index.php' as part of URL.

    What else can I do?



  • @zforest Do you have a .htaccess file in mySite.com/vr/ ?
    It looks like if you have to add index.php to your URL, mod_rewrite is not installed or not configured.



  • In my apache2's httpd.conf

    the line for the rewrite module is not commented out

    In addition to my site's .htaccess file, I also set the httpd.conf's <directory>...</directory> for htdocs to have the same AllowRewrite All.

    and I restarted apache regardless.

    Is there some way to debug ? Could I have a php script that tells me whether if rewrite module is really enabled or not?



  • @zforest Create a php file in your web root and add the following line to it: phpinfo();
    Then open the php file in your browser and search for mod_rewrite .

    https://stackoverflow.com/questions/7337724/how-to-check-whether-mod-rewrite-is-enable-on-server



  • Previously I was placing IdealSpaceVR in wordpress. Now I'm setting up a new app (IdeaSpaceVR) anew like this:
    https://docs.bitnami.com/aws/infrastructure/lamp/administration/create-custom-application-php/

    I also created a .htaccess file at /opt/bitnamic/apps/vr/htdocs/.htaccess
    with
    <Directory /opt/bitnami/apps/vr/htdocs>
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    Now I get "internal access error" instead of 404

    If I remove the .htaccess, I can see the regular IdeaSpaceVR splash page but no installation

    So still stuck 😞



  • @zforest Use the .htaccess file which is shipped with IdeaSpaceVR:

    DirectoryIndex index.php
    
    <FilesMatch "artisan|composer.phar|composer.json|composer.lock|package.json|web.config|.env|gulpfile.js|laravel.log">
        Order Allow,Deny
        Deny from all
    </FilesMatch>
    
    <IfModule mod_rewrite.c>
        <IfModule mod_negotiation.c>
            Options -MultiViews
        </IfModule>
    
        # Do not allow directory listings
        Options -Indexes
    
        RewriteEngine On
    
        # Redirect Trailing Slashes If Not A Folder...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)/$ /$1 [L,R=301]
    
        # Handle Front Controller...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^ index.php [L]
    </IfModule>
    

Log in to reply