Enable nice URLs / mod_rewrite for Apache web server


  • administrators

    If you see index.php in the web browser URL path, IdeaSpaceVR won't work correctly and you need to enable the mod_rewrite module in your Apache web server.

    1. Log in to your server.

    2. Execute sudo a2enmod rewrite

    3. Restart Apache sudo systemctl restart apache2 or sudo service apache2 restart



  • @WeddingDJ

    I have enabled the mod_rewrite as well as restarted Apache2. I still see the index.php before every file. Any other ideas?

    Thanks,
    Heather



  • I got some help!!! It was an apache permission problem. Preview and publish are now working!!! A colleague found this link: https://stackoverflow.com/questions/18740419/how-to-set-allowoverride-all

    Below was the problem and answer:

    In case you are on Ubuntu, edit the file /etc/apache2/apache2.conf (here we have an example of /var/www):

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
    </Directory>

    and change it to;

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    then,

    sudo service apache2 restart


  • administrators

    @drhstone Great, thanks for sharing!


Log in to reply