Videosphere ending and Content not Displaying



  • Hello,

    Two questions 🙂

    1. What ending is the videospheres looking for? .mov is not working for me as it does not recognize it as a video.

    2. The preview or the publish are not working. I created an IdeaSpace 360 and then added 5 photospheres with images, titles, and description. When I click on preview I only see a webpage with a list of the titles and no images. I published and then I see the same thing.

    Any help would really be appreciated as always!

    Heather



  • @drhstone

    1. mp4 video format
    2. which web browser are you using? Do you see index.php in the URL path (which you should not, otherwise mod_rewrite is not working)?


  • @WeddingDJ

    Thanks AGAIN 🙂 I got the video file up.

    I tried both chrome and firefox and I get the same thing of only seeing the titles and the color choices I made for them. I do see index.php in the URL path so I went to GitHub and got the following and changed the index.php file. I really appreciate your time this week. I cannot wait to show off your product at Mozz fest this weekend. I really think that I am almost there. Also, once I get this under control I am planning on adding in some of the new A-Frame functionality so I can use this in the K-12 classroom! So hang in there with me please 🙂

    <FilesMatch "artisan|composer.phar|composer.json|composer.lock|package.json|web.config|.env|gulpfile.js|laravel.log">
    Order Allow,Deny
    Deny from all
    </FilesMatch>

    <IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
    Options -MultiViews
    </IfModule>

    # Do not allow directory listings
    Options -Indexes
    
    RewriteEngine On
    
    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)/$ /$1 [L,R=301]
    
    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
    

    </IfModule>



  • @drhstone index.php must not be visible in the path, that's why the scene is not rendered properly. Please make sure mod_rewrite is enabled in apache. sudo a2enmod rewrite and sudo service apache2 restart.


Log in to reply