Blurry output for photospheres



  • Hi, I was creating a tour using photo tour, and also I created the same tour using simple a-frame coding. The quality of image was vastly different, as ideaspace tour image was looking blurry. Any reason for this and how to rectify this?

    Ideaspace image snip:
    0_1527933887258_Screen Shot 2018-06-02 at 3.27.42 PM.png

    Basic A-frame code image snip:
    0_1527933945820_Screen Shot 2018-06-02 at 3.27.32 PM.png


  • administrators

    @thomas Hi, uploaded photo sphere images are resized to the nearest power of two dimensions in order to avoid resizing by A-Frame / three.js.

    What is the original resolution of your photo sphere?

    The next IdeaSpaceVR release will have an option to avoid automatic resizing:

    0_1528081336077_Screen Shot 2018-06-03 at 22.59.22.png



  • I checked for the resizing issue and the image already has power of 2 dimensions (4096*2048). So both have same resolutions but image quality varies. Also, I tried the newer version to prevent auto resize, but same issue.


  • administrators

    @thomas In your A-Frame code, do you use a-sky?

    In the photo tour I am using an entity having the same radius as a-sky (5000), the only difference is in the material component, I use side:double whereas a-sky uses side:front AND segmentsHeight: 64 instead of segmentsHeight: 20 in a-sky

    In /themes/ideaspace-360-photo-tour/views/scene.blade.php

    <a-entity
                    geometry="primitive: sphere; radius: 5000; segmentsWidth: 64; segmentsHeight: 64"
                    material="shader: flat; side: double; color: #FFFFFF"
                    scale="-1 1 1"
                    rotation="0 -90 0" id="photosphere">
    

    You could change the segementsHeight attribute in the photo tour scene. If this solves the issue, it would be a bug in the theme.

    UPDATE: could you attach both photo sphere images to a post? the original one which you use in your coded a-frame scene and the blurry one which is shown in the photo tour space?


  • administrators

    @thomas My photospheres do not show quality differences before and after upload, but I guess the differences are just not visible. For debugging it would help if you could send me your original photosphere image as the quality issue is very visible.


Log in to reply