Installation fails on unmanaged VPS LAMP server



  • Dear forum members,

    I am trying to install the IdeaSpace package on an unmanaged VPS with Debian 8. As it was a clean empty Debian install, I installed Apache 2.4, Mysql, PHP myself and set up a domain. I also installed a certificate to be able to use HTTPS.

    I checked if all PHP extensions from the installation instructions were there. It took me a lot of time, but eventually all prerequisites seem to be met. I could access a test.php file and it returned a detailed configuration overview which I think is fine, as all php extensions seem to be enabled. I could view a test index.html file via https also.

    Then I uploaded the IdeaSpace files (including .htaccess etc) into the document root of /var/www/my.domain.com/public_html.
    Following the instructions, I pointed my browser to it but to no result, only a blank browser screen. No 404 error message. Then I tried to use the URL https://www.my.domain.com/index.php, but no result. The URL in the browser changed to https://www.my.domain.com/index.php/install, but nothing further happened.

    I am stuck now and have no clue what to check to make it work. All php modules seem to be enabled, I could parse the test.php file, https is working etc. I hope to get help here to make this wonderful application work. Thanks in advance!

    Miguel
    the Netherlands



  • An URL like this: https://www.my.domain.com/index.php/install means that .htaccess is not taken into account.

    But I think there is another problem with the php configuration in Apache since the install page is not showing up (on that page you would see if all necessary php extensions are installed).

    Did you install these packages (don't know if these have the same names in Debian)?
    sudo apt-get install php libapache2-mod-php php-mcrypt php-mysql
    sudo apt-get install mysql-server

    Did you restart apache after installing php?

    You could enter some php code into your test.php file and see if it is executed at all.

    I usually follow these instructions https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-16-04



  • @WeddingDJ

    Thank you for your comments, I will look into this and report back.

    Best regards,
    Miguel



  • It is possible to view the test.php output, which show similar phpinfo as the digitalocean instructions. I changed the mysql dir.conf file to check for index.php files first. When I point the browser to https://www.domain.com, now I get a 404 error stating that : "The requested URL /install was not found on this server".

    When using the file manager on my pc to find something with "install" in it, I found two install directories and some content in the main Ideaspace folder, but I could not see them in the directory tree by default. Also, when browsing the Ideaspace directory with my ftp manager (filezilla), no display of these directories. Strange. I checked the zip archive, also no install directory, but it has to be there as I could find them when I unzipped them. Also on the server, no install directories. Are these hidden in some way?



  • Well, I found the install directories in the ideaspace folder tree, f.e. in blabla/public/assets. The question is why the requested url/install was not found.



  • @Miguel The install path does not exist as a directory, it is a so-called route and it is configured in app/Http/routes.php

    Did you enable mod_rewrite?

    a2enmod rewrite

    /etc/init.d/apache2 restart



  • @ WeddingDJ: thank you for your advise, really appreciate it, I mod_rewrite is enabled and apache restarted, I did this check some time ago when reading other forum entries.

    In the apache2 error.log I found this:

    [Thu Apr 12 00:14:39.161920 2018] [:error] [pid 21375] [client
    158.69.229.134:59409] PHP Fatal error: Uncaught exception
    'UnexpectedValueException' with message 'The stream or file
    "/var/www/my.domain.com/public_html/storage/logs/laravel.log" could not be
    opened: failed to open stream: Permission denied' in
    /var/www/my.domain.com/public_html/vendor/monolog/monolog/src/Monolog/Handler/
    StreamHandler.php:107\nStack trace:\n#0
    /var/www/my.domain.com/public_html/vendor/monolog/monolog/src/Monolog/Handler/
    AbstractProcessingHandler.php(37):
    Monolog\Handler\StreamHandler->write(Array)\n#1
    /var/www/my.domain.com/public_html/vendor/monolog/monolog/src/Monolog/Logger.php(
    336): Monolog\Handler\AbstractProcessingHandler->handle(Array)\n#2
    /var/www/my.domain.com/public_html/vendor/monolog/monolog/src/Monolog/Logger.php(
    615): Monolog\Logger->addRecord(400,
    Object(Symfony\Component\Debug\Exception\FatalErrorException), Array)\n#3
    /var/www/my.domain.com/public_html/vendor/laravel/framework/src/Illuminate/Log/
    Writer.php(202):
    Monolog\Logger->error(Object(Symfony\Component\Debug\Exception\
    FatalErrorException), Array)\n#4 /var/www/my.domain. in
    /var/www/my.domain.com/public_html/vendor/monolog/monolog/src/Monolog/Handler/
    StreamHandler.php on line 107

    I guess certain logfiles cannot be written due to permission denied. I must say that I do not know how to change the permission so the log can be written. Also the last FatalErrorExeption look strange to me, the .com in my.domain is not there, just my.domain (dot). But maybe it should not.

    Thanks again!
    Miguel



  • @Miguel

    Directories within the storage, bootstrap/cache and public/assets/user directories must be writable by your web server. The files config/database.php and config/app.php must be writable by your web server as well.
    

    You can change file and directory permissions for the web server user with chmod.



  • @WeddingDJ

    Thank you, that's what I found out too, when searching on the internet. Seems to be a common problem. I will implement the needed permissions. and see what happens. Great help, I am no whizzkid although I have linux experience, so have to learn on the job 😉



  • @Miguel Yes it is a common problem / needed procedure when installing web apps. I tried to keep the install process as simple as possible, a bit like a Wordpress installation.



  • @WeddingDJ: Unfortunately, no results. When pointing the browser to https://www/my.domain.com, I still get the 404 error: "URL/install not found". I changed the permissions with chmod -R 0770 www-data for the mentioned directories and chmod 0770 www-data for the mentioned files. With chgrp www-data I changed the group too. See below for the permissions etc. for the directories and files you mentioned. The rest I left untouched.

    Also, I changed the .htaccess file as per instructions on the ISVR website, when you get the 404 error. See below. No apparent change, still 404 error.

    -rw-r--r-- 1 root root 780 Apr 13 19:57 .htaccess
    -drwxr-xr-x 3 root root 4096 Feb 16 19:23 bootstrap
    -rw-r--r-- 1 root root 1780 Feb 16 19:23 index.php
    drwxrwx--- 5 root www-data 4096 Feb 16 19:23 storage
    drwxrwx--- 2 root www-data 4096 Apr 13 19:35 cache
    drwxrwx--- 8 root www-data 4096 Feb 16 19:23 user
    -rwxrwx--- 1 root www-data 9248 Feb 16 19:23 app.php
    -rwxrwx--- 1 root www-data 3877 Feb 16 19:23 database.php

    .htaccess file:

    DirectoryIndex index.php

    <Directory /var/www/my.domain.com/public_html>
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    <FilesMatch "artisan|composer.phar|composer.json|composer.lock|package.json|web.config|.env|gulpfile.js">
    Order Allow,Deny
    Deny from all
    </FilesMatch>

    <IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
    Options -MultiViews
    </IfModule>

    # Do not allow directory listings
    Options -Indexes
    
    RewriteEngine On
    
    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)/$ /$1 [L,R=301]
    
    # Handle Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
    

    </IfModule>



  • Well, setting the group to www-data was not such a good idea 😟 : the affected directories were browsable. I changed it back to root. I am now still finding out the right permissions for what directory. Should app.php be executable for visitors (world) f.e.? And index.php? Or just readable but not writable and executable? Is this pre-set for the downloaded and unzipped ISVR files or do I have to configure it, or only the aforementioned directories and files? I am a bit puzzled about this one, it would be good for newbies to have additional instructions for this matter in the manual. Anyway I hope I will get there and have a working application soon.

    For now, I set permissions to 770 to be safe, until I can safely give more permissions to visitors when my understanding is better.



  • I have been comparing the (pre-set) permissions on the files that i unzipped on my fedora home pc, with the permissions on the server. To my unpleasant surprise, it seems that the write permissions on the directories and files on the server are all disabled I started to make the permissions on the server the same as from the unzipped and uninstalled files I originally downloaded to my home pc. But this is a very tedious task, to change all by hand. On directories, one can use chmod -R, but not on the *.php files. There are a lot of php files..

    So my questions: how is this possible, that the permissions were changed? I sftp'ed the zip file to the server as a regular user k3dadm (because I blocked ssh for root access for security reasons), su'ed to root, copied the zip file from the home k3dadm directory to /var/www/my.domain.com/ and unzipped as root. Because the unzip command also produced the IdeaSpace-1.1.0 root directory, I deleted the public_html folder (there was nothing in there anyway) and mv'ed the IdeaSpace folder to public_html folder, in order to have a public_html folder again. Somewhere in the process all write permissions were stripped off. I am very puzzled now.

    It seems that in the original zip file, all directories have drwxrwxr-x permissions and all php files -rw-rw-r-- permissions, but not on my server. Is there a quick way to give back all original permissions to the php files in the directory tree? Some chmod command that works -say- through all directories at once? To change this for the whole directory tree, for directories one can use chmod -R, is something like this also possible for all php files at once? Or should I enable root on ssh again, ftp as root and then re-unzip everything? Will the permissions preserved then?
    Thanks again!



  • So, I enabled root access on ssh again, sftp'ed the zip file to the /var/www/mydomain.com again and unzipped. Still the same phenomenon: on the group permissions, the write permission is stripped off. I have no clue why...

    By the way, uploading the already unzipped files from my home computer (with group write enabled) leads to the same results. So it does not look like an "unzip" issue to me.

    With the command: unzip -Z IdeaSpace-1.1.0.zip I get totally different permissions in the zipfile than when actually extracted. Unzip -Z shows the permissions as set in the zip file.



  • @WeddingDJ: I made the installation to work and now the next hurdle showed up. I cannot connect to the database. I created a user in mysql, created a database, granted permissions to the user. The user is able to login to mysql. Bytheway, is logging in in mysql different from logging in on a database?

    I have read one of your posts about connecting to a database, but I do not understand how and where to specify the hostname together with the database name. Could you specify this more? Thank you in advance!



  • @ WeddingDJ and others: Hurray, I got it installed! It took a lot of time and I learned a lot doing the installation.
    Special thanks to WeddingDJ 👏

    The only thing I am worried about is the following: to make it work, I set all directory and file permissions to 0770 and modified the group to www-data to make it writable for the webserver. Now, I can browse trough the different directories from outside. Any tips to prevent this without disturbing the access from apache?

    Thanks!



  • @WeddingDJ :

    I am sorry to say that my installation is running, but it generates internal server errors when uploading 3D models. I installed the 3d-model theme and created a new space. Then I tried to upload a model. I have set the php.ini memory limit to 512MB and max. filesize to 100MB. The models I tried to upload varied in size between 13MB and 78MB, .OBJ, Collada formats.

    I checked the laravel.log file for errors and found serveral errors. I cannot interpret those unfortunately. Some examples:

    [2018-04-14 16:51:27] local.ERROR: exception 'BadMethodCallException' with message 'Method hasInput does not exist.' in /var/www/my.domain.com/public_html/vendor/laravel/framework/src/Illuminate/Support/Traits/Macroable.php:74

    2018-04-14 16:53:19] local.ERROR: exception 'ErrorException' with message 'Undefined variable: model_obj' in /var/www/my.domain.com/public_html/storage/framework/views/feaacd99492406e0cea13d5303d986a50d46d0ce.php:8

    Next exception 'ErrorException' with message 'Undefined variable: model_obj (View: /var/www/my.domain.com/public_html/resources/views/admin/asset_library/model_obj_mtl_preview.blade.php)' in /var/www/my.domain.com/public_html/storage/framework/views/feaacd99492406e0cea13d5303d986a50d46d0ce.php:8

    If you wish, I can send you a more detailed log file?

    By the way, the vps specification is: 1GB of memory, one Xeon processor. Memoryload is 209MB for OS, webserver and IS application.

    In the /var/www/my.domain.com/logs directory I found in the error log these lines:

    [Sat Apr 14 18:37:55.350168 2018] [:error] [pid 10015] [client xx.xxx.xx.xxx:51941] PHP Warning: POST Content-Length of 59628127 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: https://my.domain.com/index.php/admin/space/1/edit/model/add

    I have set the post limit in php.ini to 0 (unlimited), now the files load up correctly (59MB 😉 but the two turning arrows keep turning. According to lavarel.log:

    [2018-04-15 13:45:40] local.ERROR: exception 'Intervention\Image\Exception\NotSupportedException' with message 'GD Library extension not available with this PHP installation.' in /var/www/my.domain.com/public_html/vendor/intervention/image/src/Intervention/Image/Gd/Driver.php:16

    Now, I previously installed the ImageMagick extension, not the GD library extension. Should I install the GD library extension as well?

    I could view the uploaded .dae model in the assets, it appears it shows only vertice color, not the texture. Also, I could rotate the model, but could not zoom in or out nor displace the model in the viewport. Further, model preview gives me a blank page and nothing happens.



  • @Miguel Did you try installing the GD Library extension?

    Did you go through the IdeaSpaceVR installation process? I am asking because it tests wether GD or Imagick is installed.

    Did you upload the texture files for you .dae model (at the same time when uploading the model)?

    Regarding file permissions: only www-data group should have write rights on a couple of directories where it is needed (see installation docs).



  • @WeddingDJ
    I just saw that you can configure using Imagick instead of GD in the config file under config/image.php



  • Hi @WeddingDJ ,

    The installation process went o.k., with all green checkmarks. I have modified the config/image.php and now it shows the thumbnail.
    By the way, I discovered the console in the debugging tools of firefox (quantum 59). I am not a developer so most is abracadabra to me, but I noticed the following:

    From the admin page, trying to preview a space (myspace):

    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/aframe/aframe-v0.7.1.min.js’ has failed.
    myspace:28
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/gradientsky.min.js’ has failed.
    myspace:29
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/aframe-html-shader-component/aframe-html-shader.min.js’ has failed.
    myspace:30
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/aframe-extras/aframe-extras.loaders.min.js’ has failed.
    myspace:31
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/aframe-orbit-controls/aframe-orbit-controls-component.js’ has failed.
    myspace:32
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/kframe/aframe-look-at-component.min.js’ has failed.
    myspace:33
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/isvr-vr-mode.js’ has failed.
    myspace:34
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/isvr-model-center.js’ has failed.
    myspace:35
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/isvr-hotspot.js’ has failed.
    myspace:36
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/isvr-annotation.js’ has failed.
    myspace:37
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/isvr-teleportation.js’ has failed.
    myspace:38
    Loading of <script> with source ‘https://www.my.domain.com/index.php/themes/ideaspace-3d-model/js/main.js’ has failed.

    it is possible to view the uploaded model in the assets preview. I can only rotate a bit and the viewers perspective is very strange. No zooming in or out nor panning possible.

    Here is the output when opening the assets preview screen(it is in dutch, sorry I cannot translate it to english, I hope you can interpret nevertheless):

    Onbekende eigenschap ‘-moz-osx-font-smoothing’. Declaratie genegeerd.
    font-awesome.min.css:4:662
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    font-awesome.min.css:4:1900
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    font-awesome.min.css:4:2063
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    font-awesome.min.css:4:2229
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    font-awesome.min.css:4:2400
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    font-awesome.min.css:4:2573
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    assets.css:24:11
    Fout tijdens het parsen van waarde voor ‘-webkit-text-size-adjust’. Declaratie genegeerd.
    normalize.less:11:2
    Onbekende pseudo-klasse of pseudo-element ‘-webkit-inner-spin-button’. Regelset genegeerd vanwege foute selector.
    normalize.less:346
    Onbekende pseudo-klasse of pseudo-element ‘-webkit-search-cancel-button’. Regelset genegeerd vanwege foute selector.
    normalize.less:367
    Onbekende eigenschap ‘orphans’. Declaratie genegeerd.
    bootstrap.css:228:3
    Onbekende eigenschap ‘widows’. Declaratie genegeerd.
    bootstrap.css:237:2
    Onbekende eigenschap ‘-moz-osx-font-smoothing’. Declaratie genegeerd.
    glyphicons.less:35:47
    Fout tijdens het parsen van waarde voor ‘outline’. Declaratie genegeerd.
    scaffolding.less:70:2
    Fout tijdens het parsen van waarde voor ‘margin-top’. Declaratie genegeerd.
    forms.less:60:2
    Fout tijdens het parsen van waarde voor ‘outline’. Declaratie genegeerd.
    forms.less:84:2
    Onbekende pseudo-klasse of pseudo-element ‘-ms-input-placeholder’. Regelset genegeerd vanwege foute selector.
    vendor-prefixes.less:108:34
    Onbekende pseudo-klasse of pseudo-element ‘-webkit-input-placeholder’. Regelset genegeerd vanwege foute selector.
    forms.less:137:4
    Onbekende pseudo-klasse of pseudo-element ‘-ms-expand’. Regelset genegeerd vanwege foute selector.
    forms.less:146:2
    ‘-webkit-min-device-pixel-ratio’ gevonden waar naam van mediafunctie verwacht.
    bootstrap.css:2605
    Fout tijdens het parsen van waarde voor ‘margin-top’. Declaratie genegeerd.
    bootstrap.css:2656:14
    Onbekende eigenschap ‘user-select’. Declaratie genegeerd.
    bootstrap.css:3011:1
    Fout tijdens het parsen van waarde voor ‘outline’. Declaratie genegeerd.
    bootstrap.css:3033:20
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    bootstrap.css:3043:1
    Fout tijdens het parsen van waarde voor ‘border-top’. Declaratie genegeerd.
    dropdowns.less:20:18
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    bootstrap.css:3575:1
    Fout tijdens het parsen van waarde voor ‘border-bottom’. Declaratie genegeerd.
    dropdowns.less:194:4
    Niet-herkende at-regel of fout bij parsen van at-regel ‘@-o-keyframes’.
    progress-bars.less:18:2
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    bootstrap.css:5130:1
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    progress-bar.less:4:2
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    progress-bar.less:4:2
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    progress-bar.less:4:2
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    media.less:3:2
    Onbekende eigenschap ‘zoom’. Declaratie genegeerd.
    media.less:21:2
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    bootstrap.css:5851:10
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    close.less:28:4
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    opacity.less:4:2
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    modals.less:80:2
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    tooltip.less:18:2
    Onbekende eigenschap ‘line-break’. Declaratie genegeerd.
    bootstrap.css:5988:1
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    tooltip.less:19:32
    Onbekende eigenschap ‘line-break’. Declaratie genegeerd.
    popovers.less:28:14
    ‘transform-3d’ gevonden waar naam van mediafunctie verwacht.
    vendor-prefixes.less:60:10
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    gradients.less:12:4
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    carousel.less:113:4
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    gradients.less:11:4
    Fout tijdens het parsen van waarde voor ‘background-image’. Declaratie genegeerd.
    bootstrap.css:6346:19
    ‘progid’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    carousel.less:123:4
    ‘alpha(’ gevonden waar ‘not’, URL of filterfunctie verwacht. Fout tijdens het parsen van waarde voor ‘filter’. Declaratie genegeerd.
    bootstrap.css:6356:10
    ‘#000\9 ’ gevonden waar kleur verwacht. Fout tijdens het parsen van waarde voor ‘background-color’. Declaratie genegeerd.
    carousel.less:209:4
    Niet-herkende at-regel of fout bij parsen van at-regel ‘@-ms-viewport’.
    bootstrap.css:6525:1
    A-Frame Version: 0.7.1 (Date 18-10-2017, Commit #0da6cf4)
    aframe-asset-library-v0.7.1.min.js:388:2257
    three Version: ^0.87.0
    aframe-asset-library-v0.7.1.min.js:388:2330
    WebVR Polyfill Version: ^0.9.36
    aframe-asset-library-v0.7.1.min.js:388:2383
    Onbekende pseudo-klasse of pseudo-element ‘-webkit-full-screen’. Regelset genegeerd vanwege foute selector.
    assets:1:121
    Fout tijdens het parsen van waarde voor ‘cursor’. Declaratie genegeerd.
    assets:1:333
    Fout tijdens het parsen van waarde voor ‘cursor’. Declaratie genegeerd.
    assets:1:433
    Selector verwacht. Regelset genegeerd vanwege foute selector.
    assets:1:450
    Fout bij brontoewijzing: request failed with status 404
    Bron-URL: https://www.my.domain.com/public/aframe/aframe-asset-library-v0.7.1.min.js
    Brontoewijzings-URL: aframe-v0.7.1.min.js.map[Meer info]
    Fout bij brontoewijzing: request failed with status 404
    Bron-URL: https://www.my.domain.com/public/jquery/jquery.min.js
    Brontoewijzings-URL: jquery.min.map[Meer info]

    The thing that I have tried is setting the permissions on the files higher etc. but it dit not change the situation.

    From the Edit Model Details screen: it loads the model, but these messages are shown in the debugger (I understand the image message, I hoped that it would be possible to load 8192x8192 textures 😉

    THREE.WebGLRenderer 87
    aframe-asset-library-v0.7.1.min.js:105:29383
    core:a-assets:warn Asset loading timed out in 3000 ms
    aframe-asset-library-v0.7.1.min.js:26:633
    THREE.WebGLRenderer: image is too big (8192x8192). Resized to 4096x4096
    <img crossorigin="anonymous" src="https://www.my.domain/public/assets/user/model3d/FAMs1hyfg1aZLTHys3thP95Lsl75YE/Mare .jpg">
    aframe-asset-library-v0.7.1.min.js:104:23681


Log in to reply