Large (4k or 7776 x 3888) Images do not upload - Solved



  • Hello,

    I'm having trouble getting any of my images taken with the Samsung Gear 360 (2016) camera. I get a progress bar going to 100% and then nothing.

    I've uploaded some of the google VRView examples and they all upload instantly.

    What am I doing wrong?

    Rob



  • Hmmmm - it's weird, when I log into the FTP I can see that the 360 files have actually uploaded correctly, they just don't appear as a photosphere



  • Which theme do you use exactly?

    For some devices the maximum texture resolution is 4096 x 2048. Could you give me the resolution of your uploaded photospheres? I guess the resolution is too large, if you could point me to your site then I could download some of your photospheres and do a test.

    Thanks for reporting!



  • So one of the images I'm trying to get working is 7776 x 3888 - when I check the assets directory from my ftp link I can see that the image has uploaded correctly - in fact it can be accessed here:

    http://leeds3.azurewebsites.net/vr/public/assets/user/photospheres/WR022t9UuJxxkB9fzuUZBmVU62PGFYNn9AqeHF7eyMIeo3DcbISpl12svnWe.jpg

    The image does not appear as an asset in the photospheres though. None of the images I'm uploading from the camera work.

    I'm using the IdeaSpace 360 theme and the one with Navigation in.



  • So I've dropped the resolution down to 4096 x 2048 and it uploads and adds into the photosphere assets just fine.

    Is there a way to increase the max resolution?



  • Thanks for the example image. I will play with it and come back to you.



  • I just uploaded it by using the IdeaSpace 360 theme and it worked fine on my desktop and on an old nexus 5 phone using Cardboard.

    Which device are you using? Or which web browser? Do you have errors in the web browser console?

    UPDATE: I remembered that the uploaded image is automatically resized to 4096 x 2048 after uploading, in order to avoid issues with texture sizes. It looks like that your image is not being resized after uploading and there might be an issue with your GD or ImageMagick PHP library, although there is a check during installation of IdeaSpaceVR if one of these libraries are installed. You did not have an issue when installing IdeaSpaceVR, or?
    Could you give me a version number of GD or ImageMagick you have on your server?



  • I've tried the same in the latest version of Chrome and Edge - here is the console in chrome

    ![0_1507651852538_Capturel.JPG](Uploading 100%)



  • @lnsertacoin I just updated my previous message



  • This post is deleted!


  • @lnsertacoin No problem. You could create a file named test.php and add the following lines in it:

    <?php phpinfo(); ?>

    Put the file in your web root and open it. It will show you your php configuration and you can search for GD or ImageMagick.

    Please delete the file afterwards as it is not secure to leave it online.



  • I've just added extension - ImagickExtension v0.1.5



  • @lnsertacoin And does it work now?



  • Nope

    gd

    GD Support enabled
    GD Version bundled (2.1.0 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.7.0
    GIF Read Support enabled
    GIF Create Support enabled
    JPEG Support enabled
    libJPEG Version 9 compatible
    PNG Support enabled
    libPNG Version 1.5.26
    WBMP Support enabled
    XPM Support enabled
    libXpm Version 30512
    XBM Support enabled
    WebP Support enabled



  • If you navigate to your dashboard on your IdeaSpaceVR installation, in the "At a Glance" box, what are the four MB values? - It could be that you run out of memory when your server tries to resize large images, that's possibly why the low resolution image (4096 x 2048) works.



  • @Chris

    MaxUpload - 8MB
    MaxPost - 8MB
    Mem Usage - 2MiB
    Mem Limit - 256M



  • @lnsertacoin Thanks, so this does not seem to be an issue, I only have 128M memory.

    Another idea: could you send me your log files from storage/logs/laravel.log by e-mail to chris AT ideaspacevr.org ? - Mabye there is an error logged in there.



  • Thanks to Chris for helping me out with this - I found that my php.ini file needed to be amended to a higher memory limit. I changed it to:

    memory_limit = 512M

    and everything now works a treat. It should be noted that images are down scaled to 4096 x 2048, but you can now upload larger files without error using this fix.



  • I'm having a similar problem but with videosphere uploads. I have the memory limit to 512M and the progress bar stays at 100% but doesn't finish the upload. The videosphere files usually are large (around 30MB or more depending on quality). I was wondering if there is a way to upload these files through FTP like FileZilla? Please let me know.



  • @johnsavath The videosphere uploads should finish. Could you open the developer console and look if there are any errors shown, when uploading your videosphere?

    You could try to set the memory limit higher and try uploading again. Also make sure that the other values as shown on the dashboard (in "At a Glance") are set high enough to allow the upload of large files.

    You cannot upload the video files directly because you need the videosphere entries in the database, which are generated when you upload a videosphere.


Log in to reply